Главное меню  

   

Авторизация  

   
   
Хостинг в Украине
   


42.2%Russian Federation Russian Federation
38.6%United States United States
5.8%Ukraine Ukraine
5.7%Canada Canada
1.5%Romania Romania
0.6%Belarus Belarus
0.6%Kazakhstan Kazakhstan
0.5%United Kingdom United Kingdom
0.5%China China
0.4%Czech Republic Czech Republic

Сегодня: 14
Вчера: 50
На прошлой неделе: 965
В этом месяце: 491
В прошлом месяце: 2954
Всего: 9545


   

блог админа

Записи

  • Главная
    Главная Страница отображения всех блогов сайта
  • Категории
    Категории Страница отображения списка категорий системы блогов сайта.

Программа вывода числа в столбик

Добавлено : Дата: в разделе: Занимательная информатика

 

Алгоритмический язык   Питон

алг Вывод числа в столбик
нач
цел n
ввод n
F(n)
кон
алг F(цел n)
нач
если n > 0 то
F(div(n,10))
вывод mod(n,10),нс
все
кон

                 

def st(n):
     if n>0:
          st(n//10)
          print(n%10)
n=int(input())
st(n)

 

 

Редактировалось Дата:

You have no rights to post comments

   
© 2012 fordus.