Главное меню  

   

Авторизация  

   
   
Хостинг в Украине
   


67.7%Russian Federation Russian Federation
13.5%Ukraine Ukraine
3.4%United States United States
2.6%China China
2.1%Romania Romania
1.9%Australia Australia
1.1%Belarus Belarus
1%Czech Republic Czech Republic
0.9%United Kingdom United Kingdom
0.9%Kazakhstan Kazakhstan

Сегодня: 4
Вчера: 15
На этой неделе: 4
На прошлой неделе: 155
В этом месяце: 19
В прошлом месяце: 1552
Всего: 4732


   

блог админа

Записи

  • Главная
    Главная Страница отображения всех блогов сайта
  • Категории
    Категории Страница отображения списка категорий системы блогов сайта.

Массивы в программе Кумир. Находим четные числа

Добавлено : Дата: в разделе: Прикладная информатика

В среде Кумир массив объявляют как "целтаб а[1..5]" ( квадратных скобках колличество элементов, которые допускается вводить, а целтаб означает что наши числа будут целые.)

алг
нач
целтаб а[1:5], цел з, x, y //объявляем массив и переменные
нц для з от 1 до 5 // цикл для ввода элементов массива
ввод а[з] //ввод массива
кц // конец цикла
x:=0 //обнуляем х
y:=0 //обнуляем х
нц для з от 1 до 5 // цикл для поиска четных чисел
если (mod(а[з],2)=0) то //ищем четные числа ( если число делится на 2 и в остатке 0)
x:=x+а[з] // Сумма четных чисел
y:=y+1 // колличество четных элементов в массиве
все
кц
вывод "X =",x
вывод "Y =",y
кон

 

Редактировалось Дата:

You have no rights to post comments

   
© 2012 fordus.