Главное меню  

   

Авторизация  

   
   
Хостинг в Украине
   


33.7%Russian Federation Russian Federation
31.2%Ukraine Ukraine
18.9%United States United States
2.6%Belarus Belarus
2.3%Czech Republic Czech Republic
2%Kuwait Kuwait
2%Kazakhstan Kazakhstan
1.4%France France
1.1%Romania Romania
0.8%Germany Germany

Сегодня: 4
Вчера: 151
На этой неделе: 155
На прошлой неделе: 825
В этом месяце: 1639
В прошлом месяце: 2042
Всего: 6906


   

блог админа

Записи

  • Главная
    Главная Страница отображения всех блогов сайта
  • Категории
    Категории Страница отображения списка категорий системы блогов сайта.

Урок №20 Деловая графика. Условные функции.

Добавлено : Дата: в разделе: 11 класс

Основные темы параграфа:

♦ графические возможности табличного процессора;
♦ типы диаграмм;
♦ условная функция.

Графические возможности табличного процессора

Замечательным свойством электронных таблиц является возможность графического представления числовой информации, содержащейся в таблице. Для этого существует специальный графический режим работы табличного процессора. Графики придают наглядность числовым зависимостям.

Типы диаграмм

Табличные процессоры дают возможность получать самые различные формы диаграмм и графиков. Ниже на рисунках показаны два типа диаграмм: круговая на рис. 4.1 и столбчатая на рис. 4.2. Исходные данные для этих диаграмм извлекаются из одинаковых диапазонов ячеек А2:А6 и D2:D6 таблиц из предыдущего параграфа. Первый диапазон содержит названия продуктов, второй – количество проданных единиц каждого продукта. Из диаграмм сразу видно, что наибольшим спросом у покупателей пользуется йогурт.

Informatika 9 125z

Круговую диаграмму обычно используют в тех случаях, когда нужно показать, какую часть от целого (круга) составляют отдельные величины (секторы). Столбчатая диаграмма (гистограмма) позволяет наглядно сопоставить между собой отдельные величины.

Условная функция

Продолжим обсуждение задачи об учете продажи молочных продуктов в торговом павильоне. В случае если тот или иной продукт продан полностью, необходимо организовать его подвоз в торговый павильон. Чтобы отразить это в электронной таблице, добавим в табл. 4.8 новый столбец с названием «Подвоз». В ячейках этого столбца будет высвечиваться слово «Да», если подвоз соответствующего продукта необходим, и «Нет», если продукт подвозить не надо. Разумеется, значения «Да» или «Нет» табличный процессор должен определить сам автоматически.

Для решения задачи воспользуемся условной функцией. Общий вид условной функции следующий:

ЕСЛИ(<условие>; <выражение1>; <выражение2>)

<Условие> — это логическое выражение, которое может принимать значение ИСТИНА или ЛОЖЬ. С логическими выражениями вы познакомились в главе о базах данных. В электронных таблицах они имеют тот же смысл. <Выражение 1> и <выражение 2> могут быть числами, формулами или текстами. 

Условная функция, записанная в ячейку таблицы, выполняется так: если <условие> истинно, то значение данной ячейки определит <выражение 1>, в противном случае — <выражение 2>.

В нашем случае условие означает проверку на равенство нулю количества оставшегося продукта. В качестве выражений 1 и 2 выступают текстовые константы «Да» и «Нет».

После внесенных изменений учетный документ примет вид, представленный в табл. 4.9 (в режиме отображения формул) и в табл. 4.10 (в режиме отображения значений).

Таблица 4.9. Таблица с условной функцией в режиме отображения формул

A B C D E F G
1 Продукт Цена Поставлено Продано Осталось Выручка Подвоз
2 Йогурт 5,4 250 225 =С2-D2 =B2*D2 =ЕСЛИ(E2=0;"Да";"Нет")
3 Творог 18,5 125 110 =C3-D3 =B3*D3 =ЕСЛИ(E3=0;"Да";"Нет")
4 Молоко 20 100 100 =C4-D4 =B4*D4 =ЕСЛИ(E4=0;"Да";"Нет")
5 Сметана 10,2 85 70 =C5-D5 =B5*D5 =ЕСЛИ(E5=0;"Да";"Нет")
6 Сливки 15,2 50 45 =C6-D6 =B6*D6 =ЕСЛИ(E6=0;"Да";"Нет")
7 ВСЕГО: =CУММ(F2:F6)

Таблица 4.10. Таблица с условной функцией в режиме отображения значений

A B C D E F G
1 Продукт Цена Поставлено Продано Осталось Выручка Подвоз
2 Йогурт 5,4 250 225 25 54 Нет
3 Творог 18,5 125 110 15 274 Нет
4 Молоко 20 100 100 0 300 Да
5 Сметана 10,2 85 70 15 294 Нет
6 Сливки 15,2 50 45 5 144 Нет
7 ВСЕГО: 1552

Коротко о главном

В современных табличных процессорах реализована деловая графика: возможность построения диаграмм и графиков по числовым данным в таблице.

Условная функция имеет следующий формат:

ЕСЛИ(<условие>; <выражение1>; <выражение2>)

Здесь <условие> — логическое выражение. Если <условие> истинно, то значение ячейки определяет <выражение1>, если ложно — <выражение2>.

Вопросы и задания

1. Что такое деловая графика?
2. Какой вид имеет условная функция? Как она выполняется?
3. На основании таблицы «Оплата электроэнергии» (задание 6 из § 19) постройте столбчатую диаграмму, отражающую ежемесячный расход электроэнергии в течение года.
4. По таблице «Оплата электроэнергии» с добавленным расчетом выплаченной суммы денег за каждый квартал (задание 8 из § 20) получите круговую диаграмму, отражающую относительный размер выплат в каждом квартале.
5. К таблице «Оплата электроэнергии» добавьте расчет среднемесячной платы, а также придумайте и реализуйте способ подсчета количества месяцев, плата за которые была выше среднемесячной.

Редактировалось Дата:

Добавить комментарий


Защитный код
Обновить

   
© 2012 fordus.