Главное меню  

   

Авторизация  

   
   
Хостинг в Украине
   


62.8%Russian Federation Russian Federation
16.9%Ukraine Ukraine
3.1%Kazakhstan Kazakhstan
2.9%Romania Romania
2.7%United States United States
1.8%Belarus Belarus
1.2%Republic Of Moldova Republic Of Moldova
1%Czech Republic Czech Republic
0.9%United Kingdom United Kingdom
0.8%France France

Вчера: 62
На прошлой неделе: 695
В прошлом месяце: 3135
Всего: 8292


   

блог админа

Записи

  • Главная
    Главная Страница отображения всех блогов сайта
  • Категории
    Категории Страница отображения списка категорий системы блогов сайта.

Программа вывода числа в столбик

Добавлено : Дата: в разделе: Занимательная информатика

 

Алгоритмический язык   Питон

алг Вывод числа в столбик
нач
цел n
ввод n
F(n)
кон
алг F(цел n)
нач
если n > 0 то
F(div(n,10))
вывод mod(n,10),нс
все
кон

                 

def st(n):
     if n>0:
          st(n//10)
          print(n%10)
n=int(input())
st(n)

 

 

Редактировалось Дата:

You have no rights to post comments

   
© 2012 fordus.